Help Center/ Application Operations Management/ User Guide (2.0) (Kuala Lumpur Region)/ FAQs/ Collection Management/ Why Can't AOM Monitor CPU and Memory Usage After ICAgent Is Installed?
Updated on 2024-08-05 GMT+08:00

Why Can't AOM Monitor CPU and Memory Usage After ICAgent Is Installed?

Symptom

AOM cannot monitor information (such as CPU and memory usage) after the ICAgent is installed.

Possible Cause

  • Port 8149 is not connected.
  • The node time on the user side is inconsistent with the time of the current time zone.

Solution

  1. Log in to the server where the ICAgent is installed as the root user.
  2. Check whether the ICAgent can report metrics:

    cat /var/ICAgent/oss.icAgent.trace | grep httpsend | grep MONITOR
    • If the command output contains failed, the ICAgent cannot report metrics. In this case, go to 3.
    • If the command output does not contain failed, the ICAgent can report metrics. In this case, go to 4.

  3. Check whether the port is connected.

    1. Obtain the access IP address:
      cat /opt/oss/servicemgr/ICAgent/envs/ICProbeAgent.properties | grep ACCESS_IP
    2. Check the connectivity of port 8149:
      curl -k https://ACCESS_IP:8149
      • If 404 is returned, the port is connected. In this case, contact technical support.
      • If 404 is not returned, the port is not connected. In this case, contact the network administrator to open the port and reinstall the ICAgent. If the installation still fails, contact technical support.

  4. Check the node time on the user side:

    date
    • If the queried time is the same as the time of the current time zone, contact technical support.
    • If they are different, go to 4.

  5. Reconfigure the node time on the user side:

    date -s Time of the current time zone (for example, 12:34:56)