Help Center> Server Migration Service> User Guide (Kuala Lumpur Region)> FAQs> Migration Network> How Do I Fix a Connection Failure Between the Source Server and API Gateway Due to a Busy Network?
Updated on 2024-03-15 GMT+08:00

How Do I Fix a Connection Failure Between the Source Server and API Gateway Due to a Busy Network?

Symptom

The Agent could not be started, and either of the following message was displayed:

Linux: Failed to start sms agent! Please check the network connection with below commands!

Windows: Network busy. The source server failed to connect to API Gateway.

Possible Causes

The source server cannot communicate with IAM or SMS over the Internet. In this case, check the source network.

Solution

  1. Log in to the source server.
  2. Confirm that you can access IAM and SMS on the source server.

    curl -v {Endpoint of IAM}:443

    curl -v {Endpoint of IAM}:443

    If curl fails to be executed, for example, due to a network timeout, the source server cannot access the IAM or SMS management console.

  3. Check whether the source server can access the Internet. If it cannot, locate the fault by checking the configurations of the DNS server, firewall, security group, and local network of the source server. For details, see Why Cannot an EIP Be Pinged? Then rectify the fault and restart the Agent.
  4. If a proxy server is used, check whether the proxy server is running properly.

    Common proxy problems are incorrect login credentials, network disconnections, and firewall or various software restrictions.