Help Center> Server Migration Service> User Guide (Kuala Lumpur Region)> FAQs> Target Server Configuration and Launch> Why Can't I See Data Disks on a Windows Target Server After Migration?
Updated on 2024-03-15 GMT+08:00

Why Can't I See Data Disks on a Windows Target Server After Migration?

Possible Causes

The SAN policy for the source server OS is Offline Shared. This means the data disks will be offline after migration.

Solutions

Solution 1

  1. Choose Start > Run.
  2. Enter diskmgmt.msc and press Enter to open the Disk Management window.

    In the following figure, disk 1 is offline.

    Figure 1 Offline

  3. Right-click the offline data disk and select online from the pop-up menu.

    Figure 2 Bringing the disk online

Solution 2

  1. Right-click the Start menu.
  2. Click Run and enter cmd.
  3. Run diskpart to start the disk management tool.
  4. Run list disk to list all disks on the server. In the following figure, disk 0 is online and disk 1 is offline.

  5. Run the select disk 1 command.
  6. Run the online disk command to change the disk status from offline to online.

  7. If the disk is read only after it goes online, run the attribute disk clear readonly command to remove the write protection on the disk.