ALM-29000 Impala Service Unavailable
Description
The alarm module checks the Impala service status every 30 seconds. This alarm is generated if the Impala service is abnormal.
This alarm is cleared after the Impala service recovers.
Attribute
Alarm ID |
Alarm Severity |
Automatically Cleared |
---|---|---|
29000 |
Critical |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
When the Impala service is abnormal, you cannot perform cluster operations on Impala through FusionInsight Manager. The Impala service functions are unavailable.
Possible Causes
- The Hive service is abnormal.
- The KrbServer service is abnormal.
- The Impala process is abnormal.
Procedure
Check whether the services on which Impala depends are normal.
- On FusionInsight Manager, choose Cluster > Services to check whether Hive and KrbServer are stopped.
- On FusionInsight Manager, choose O&M > Alarm > Alarms. In the alarm list, check whether the Impala Service Unavailable alarm is cleared.
- If yes, no further action is required.
- If no, go to 3.
- On FusionInsight Manager, choose O&M > Alarm > Alarms. In the alarm list, check whether ALM-16004 Hive Service Unavailable and ALM-25500 KrbServer Service Unavailable exist.
- Rectify the fault by following the handling procedure of ALM-16004 Hive Service Unavailable or ALM-25500 KrbServer Service Unavailable. Then, check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 5.
Check whether the Impala process is normal.
- On FusionInsight Manager, choose O&M > Alarm > Alarms. Check whether ALM-12007 Process Fault exists in the alarm list.
- Rectify the fault by referring to the handling method of ALM-12007 Process Fault, and then check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 7.
Collect the fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Expand the Service drop-down list, and select Impala for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearing
After the fault that triggers the alarm is rectified, the alarm is automatically cleared.
Related Information
None
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