Help Center> Distributed Message Service for RocketMQ> User Guide (Kuala Lumpur Region)> FAQs> Connection FAQs> How Do I Handle Instance Connection Failure "RemotingTooMuchRequestException: sendDefaultImpl call timeout"
Updated on 2024-04-08 GMT+08:00

How Do I Handle Instance Connection Failure "RemotingTooMuchRequestException: sendDefaultImpl call timeout"

Symptom

Connecting to a RocketMQ instance failed. The error message is "RemotingTooMuchRequestException: sendDefaultImpl call timeout".

Possible Cause

The security group does not allow the service port.

Solution

  1. On the instance details page of the RocketMQ console, view the port next to Allow Access To in the Network area.
  2. Click the security group name to view details.
  3. Add an inbound rule to allow the port obtained in 1.