Help Center> Migration Center> FAQs> Cross-AZ Migration> Why Are My Windows Data Disks Missing After the Migration?
Updated on 2024-05-06 GMT+08:00

Why Are My Windows Data Disks Missing After the Migration?

Symptom

After a Windows source server was migrated, you logged in to the target server and found that some data disks were missing on the target server. However, the ECS console showed that the target server has the same number of disks as the source server.

Possible Causes

The SAN policy Offline Shared or Offline All was used for the source server. After the migration was complete, this setting was retained on the target server, and data disks are just offline.

Solutions

There are two solutions for you to rectify this problem.

Solution 1

  1. Log in to the target server and choose Start > Run.
  2. Enter diskmgmt.msc and press Enter to open the Disk Management window.

    In the following figure, disk 1 is offline.

    Figure 1 Offline

  3. Right-click the offline data disk and select online from the pop-up menu.

    Figure 2 Bringing the disk online

Solution 2

  1. Log in to the target server and right-click Start.
  2. Click Run and enter cmd.
  3. Run diskpart to start the disk management tool.
  4. Run list disk to list all disks on the server. In the following figure, disk 0 is online and disk 1 is offline.

  5. Run select disk 1.
  6. Run online disk to change the disk status from offline to online.

  7. If the disk is read only after it is brought online, run the attribute disk clear readonly command to remove write protection from the disk.

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