Help Center/ Migration Center/ FAQs/ Server Migration/ How Do I Fix the Error "Edge failed to execute shell job" When the Server Migration Workflow Runs to the StartUpAgent Step?
Updated on 2025-07-18 GMT+08:00

How Do I Fix the Error "Edge failed to execute shell job" When the Server Migration Workflow Runs to the StartUpAgent Step?

Symptom

When the server migration workflow reached the StartUpAgent step, the error message "Edge failed to execute shell job" was reported.

Possible Causes

Security settings on the Windows source server might prevent the migration Agent from running.

Solution

  1. Log in to the Windows source server as an administrator.
  2. Click the Start menu and select Settings, or press Win+I.
  3. In the Settings window, click Update & Security.
  4. On the Update & Security page, click Windows Security.
  5. On the Windows Security page, click App & browser control.

  6. On the App & browser control page, find Check apps and files and select Off to disable this function.

    After the migration is complete, you are advised to restore the Check apps and files function to the default setting.