Help Center/ Migration Center/ FAQs/ Network Settings/ What Can I Do If Deep Collection Fails on a Source Server Due to Disabled WinRM or an Unreachable IP Address or Port?
Updated on 2024-12-06 GMT+08:00

What Can I Do If Deep Collection Fails on a Source Server Due to Disabled WinRM or an Unreachable IP Address or Port?

Symptom

Deep collection failed on a source server, and a message was displayed, indicating that WinRM was not enabled on the source server or the IP address or port was unreachable.

Possible Causes

The possible causes are:

  • The IP address or port of the source server is abnormal.
  • WinRM is not enabled on the Windows source server.

You can review the error cause in the log file on Edge. The file is located at C:\Edge\tools\plugins\collectors\rda-collector-server\logs\rda-collector-server\run.log.

If the fault is not caused by the preceding two reasons, check whether the Edge device is being used by multiple users for data collection simultaneously. In such cases, WinRM on the Edge device may disconnect from the source server.

Solution

  • Linux

    On the server where Edge is installed, open the CLI and use ping and telnet check whether the source server's public IP address and port (22 by default) are accessible. The command formats are ping {IP address of the source server} and telnet {IP address of the source server} {Port}.

    If the IP address or port is unreachable, check whether the security group of the source server allows access from the public IP address of the server with Edge installed over TCP on port 22 and over ICMP on any port. If the security group is correctly configured, perform deep collection again.

  • Windows
    1. Log in to the source server and enable WinRM. For details, see How Do I Configure WinRM and Troubleshoot WinRM Connection Problems? After WinRM is enabled, perform deep collection again. If the fault persists, go to step 2.
    2. On the server where Edge is installed, open the CLI and use ping and telnet check whether the source server's public IP address and port (5985 by default) are accessible. The command formats are ping {IP address of the source server} and telnet {IP address of the source server} {Port}.

      If the IP address or port is unreachable, check whether the security group of the source server allows access from the public IP address of the server with Edge installed over TCP on port 5985 and over ICMP on any port. If the security group is correctly configured, perform deep collection again.