Help Center/ Migration Center/ FAQs/ Network Settings/ What Can I Do If a Source Server Fails the Migration Readiness Check Because Its IP address or Port Is Unreachable?
Updated on 2024-10-21 GMT+08:00

What Can I Do If a Source Server Fails the Migration Readiness Check Because Its IP address or Port Is Unreachable?

Symptom

A Linux source server failed the migration readiness check, and a message is displayed indicating that its IP address or port was unreachable.

Possible Causes

The possible causes are:

  • The source server is stopped.
  • The IP address or port of the source server is abnormal.
  • The access is blocked by the firewall or antivirus software on the source server.

You can review the error cause in error log file on Edge. The error log file is stored in C:\Edge\logs\edge-server\error.log.

Solution

  1. Check whether the source server is stopped.

    • If it is, start the source server and try again.
    • If it is not, go to step 2.

  2. On the server where Edge is installed, open the CLI and use ping and telnet check whether the source server's public IP address and port (for example, 22) are accessible. The command formats are ping {IP address of the source server} and telnet {IP address of the source server} {Port}.

    • If both the IP address and port are reachable, go to step 3.
    • If the IP address or port is unreachable, check whether the security group of the source server allows access from the public IP address of the server with Edge installed over TCP on port 22 and over ICMP on any port. If the security group is correctly configured, perform the migration readiness check again.

  3. Check whether the access is blocked by the firewall or antivirus software on the source server. If it is, disable or adjust the blocking rule and try again.