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Help Center/ Cloud Backup and Recovery/ User Guide (Paris)/ Troubleshooting Cases/ Failed to Download or Install the Agent Required by Application-Consistent

Failed to Download or Install the Agent Required by Application-Consistent

Updated on 2024-02-05 GMT+08:00

Symptom

The system displays a message indicating that the script cannot be downloaded or the Agent fails to be installed in Linux mode 2.

Possible Causes

  • Cause 1: The DNS cannot resolve the OBS domain name.
  • Cause 2: The OpenSSL version of the target server is too early.

Solution for Cause 1

Cause 1: The DNS cannot resolve the domain name.

You need to manually change the DNS server address. Obtain the IP address from technical support. If the problem persists, try later or use the Linux mode 1 to install it.

Procedure (Linux)

  1. Log in to the server as the root user.
  2. Run the vi /etc/resolv.conf command to edit the /etc/resolv.conf file. Add the DNS server IP address above the existing name server information, as shown in Figure 1.

    Figure 1 Configuring DNS

    The format is as follows:

    nameserver DNS server IP address

  3. Press Esc, input :wq, and press Enter to save the changes and exit the vi editor.
  4. Run the following command to check whether the IP address is added. If yes, the operation is complete.

    cat /etc/resolv.conf

Procedure (Windows)

  1. Go to the ECS console and log in to the ECS running Windows Server 2012.
  2. Click This PC in the lower left corner.
  3. On the page that is displayed, right-click Network and choose Properties from the drop-down list. The Network and Sharing Center page is displayed, as shown in Figure 2. Click Local Area Connection.

    Figure 2 Page for network and sharing center

  4. In the Activity area, select Properties. See Figure 3.

    Figure 3 Local area connection

  5. In the Local Area Connection Properties dialog box that is displayed, select Internet Protocol Version 4 (TCP/IPv4) and click Properties. See Figure 4.

    Figure 4 Local area connection properties

  6. In the dialog box that is displayed, select Use the following DNS server addresses: and configure DNS, as shown in Figure 5. You need to manually change the DNS server address. Obtain the IP address from technical support. Then click OK.

    Figure 5 Configuring DNS

Solution for Cause 2

Cause 2: The OpenSSL version of the target server is too early.

  1. Use a remote management tool (such as PuTTY or Xshell) to connect to your ECS through the elastic IP address.
  2. Select the Agent version based on your needs, copy the command of installation mode 2 to the server, and change https to http in wget. Run the command as the root user.

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