Help Center> Data Lake Insight> FAQs> Datasource Connections> Datasource Connection O&M> Why Is the Error Message "communication link failure" Displayed When I Use a Newly Activated Datasource Connection?
Updated on 2024-01-23 GMT+08:00

Why Is the Error Message "communication link failure" Displayed When I Use a Newly Activated Datasource Connection?

  • Possible Causes

    The network connectivity is abnormal. Check whether the security group is correctly selected and whether the VPC is correctly configured.

  • Solution

    Example: When you create an RDS datasource connection, the system displays the error message Communication link failure.

    1. Delete the original datasource connection and create a new one. When you create a new connection, ensure that the selected Security Group, VPC, Subnet, and Destination Address are the same as those in RDS.

      Select a correct Service Type. In this example, select RDS.

      Figure 1 Creating a basic datasource connection-RDS

    2. Check the configurations of VPC.
      If the error message is still displayed after you create a new datasource connection according to Step 1, check the VPC configuration.
      • Classic datasource connections:
        • Inbound rule: Check whether the inbound CIDR block and port in the security group have been enabled. If not, create the CIDR block and port you need.
          Check whether the CIDR block and port are configured.
          Figure 2 Checking whether the CIDR block and port are configured

          If no, add it.

          Figure 3 Adding an inbound rule
        • Outbound rules: Check whether the CIDR block and port of the outbound rule are enabled. (It is recommended that all CIDR blocks be enabled.)

          Check whether the CIDR block and port are configured.

          Figure 4 Checking whether the CIDR block and port are configured

          If no, add it.

          Figure 5 Adding an outbound rule
      • Enhanced datasource connections:

        Check whether the CIDR block corresponding to the DLI queue is open. If no, add an outbound CIDR block in the VPC.

        1. Find the CIDR block corresponding to the queue bound to the datasource connection in DLI.
          Figure 6 Searching for the CIDR clock corresponding to the queue bound to the datasource connection
        2. In the VPC security group, check whether the CIDR block corresponding to the DLI queue has been configured.
          Figure 7 Checking the CIDR block corresponding to the DLI queue in the security group in the VPC

          If no, add it.

          Figure 8 Adding the corresponding CIDR to the VPC

If the fault persists, contact Huawei technical support.

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