What Can I Do If Message "no match mac found" Is Displayed When I Am Establishing the SSH Tunnel?
Description
When you use the macOS to access a cloud phone, "Permission denied" is reported during the SSH tunnel establishment. The details are as follows:
no match mac found: client hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh...
Causes
OpenSSH programs of multiple versions are downloaded or the downloaded OpenSSH is incompatible. This problem seldom occurs in the scenario where the system itself provides the SSH.
Handling Method
The following uses Windows 10 as an example:
Choose Control Panel > Programs > Uninstall a program, click any OpenSSH program, and press Option to view the number of downloaded OpenSSH programs.
- If there are multiple programs, uninstall them and retain the 8.1p1 version.
- If there is only one program, version 8.1p1 is recommended.
Download Windows OpenSSH 8.1p1 from https://www.mls-software.com/files/setupssh-8.1p1-1.exe.
Download Linux OpenSSH from https://www.openssh.com/.
SSH Tunnel Faults FAQs
- What Does Message "Authorized users only. All activities may be monitored and reported." Indicate?
- What Can I Do If Message "too open" Is Displayed When I Am Establishing the SSH Tunnel?
- What Can I Do If Message "Permission denied" Is Displayed When I Am Establishing the SSH Tunnel?
- What Can I Do If Message "no match mac found" Is Displayed When I Am Establishing the SSH Tunnel?
- What Can I Do If Message "no matching key exchange method found" Is Displayed When I Am Establishing the SSH Tunnel?
- How Do I Keep an SSH Session Uninterrupted?
- What Can I Do If I Failed to Establish an SSH Tunnel?
- What Can I Do If an Error Occurs When I Invoke the Cloud Phone Query API?
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