Help Center> MapReduce Service> Component Operation Guide (LTS)> Using CDL> CDL FAQs> Error 104 or 143 Is Reported After a CDL Job Runs for a Period of Time
Updated on 2024-05-29 GMT+08:00

Error 104 or 143 Is Reported After a CDL Job Runs for a Period of Time

Symptom

After an CDL job runs for a period of time, the YARN job fails and the status code 104 or 143 is returned. The following figure shows the returned status code 143.

Possible Causes

A large amount of data is captured to Hudi. As a result, the memory of the job is insufficient.

Procedure

  1. Log in to FusionInsight Manager and choose Cluster > Services > CDL. Click the hyperlink next to CDLService UI to access the CDLService web UI. On the data synchronization job list page, locate the row that contains the target job and choose More > Stop. After the job is stopped, choose More > Edit.
  2. Change the value of max.rate.per.partition of Hudi to 6000 and click Save.
  3. On the data synchronization job list page, locate the row containing the target job and choose More > Restart to restart the job.