Help Center> CloudTable Service> FAQs> General> What Can I Do If the Index Table Does Not Match the Data Table After CloudTable Data Is Deleted?
Updated on 2024-04-30 GMT+08:00

What Can I Do If the Index Table Does Not Match the Data Table After CloudTable Data Is Deleted?

Symptom

When you query data in the CloudTable table, the value of count is inconsistent with the number of data records in list. Data loss frequently occurs, and many links time out during project running.

Possible Causes

After data is deleted, the index table does not match the data table. As a result, an exception occurs.

Solutions

  • Short-term solution: Perform offline batch processing analysis on data streams and supplement the missing data on the next day.
  • Long-term solutions:
    • The lemon feature does not support data deletion. After data is deleted, table data cannot be queried. In this case, disable the TTL aging function of the data table.
    • Check whether the TTL enhanced index can be removed in the CBC data aging scenario.

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