Help Center> CloudTable Service> FAQs> Connection and Access> Why Is the Error "Will not attempt to authenticate using SASL (unknown error)" Reported When Connecting to HBase?
Updated on 2024-04-30 GMT+08:00

Why Is the Error "Will not attempt to authenticate using SASL (unknown error)" Reported When Connecting to HBase?

Symptom

HBase fails to be connected to when accessing CloudTable and the following error information is displayed:

Opening socket connection to server 192.168.0.107/192.168.0.107:2181. Will not attempt to authenticate using SASL (unknown error)

Possible Cause

The possible cause is as follows:

Network access failure

The link of CloudTable is an internal network address rather than a public network address. Therefore, CloudTable cannot be directly accessed from the public network. You can ping the ZooKeeper link of CloudTable on a client host. If it cannot be pinged, the network connection is abnormal.

Solution

You need to apply for an ECS as the client host to install the CloudTable client. Then, you can use the client on the ECS to access the CloudTable cluster. The ECS to be applied for and the CloudTable cluster must be in the same region, VPC, subnet, and security group. In addition, you need to configure a correct DNS server address for the ECS. For details about how to prepare an ECS, see Preparing an ECS.

Connection and Access FAQs

more