Help Center/ Cloud Eye/ FAQs/ Product Usage/ Server Monitoring/ What Can I Do If the Agent Upgrade Fails for Some Windows Servers?
Updated on 2025-10-27 GMT+08:00

What Can I Do If the Agent Upgrade Fails for Some Windows Servers?

Symptom

On the Server Monitoring page, the Agent fails to be upgraded for some Windows servers.

Possible Causes

The internal network settings of some Windows OSs may cause the Agent package download failure.

Procedure

  1. On the Task Center page, click the Agent Maintenance tab, locate the target task, and click Retry in the Operation column to upgrade the Agent again.
  2. If the upgrade still fails after multiple retries, choose different versions for cross-upgrade on the Server Monitoring page. For example, you can upgrade the Agent of the basic version to the enhanced version and then to the basic version.