Help Center/ Cloud Eye/ FAQs/ Troubleshooting/ Server Monitoring/ Troubleshooting Agent One-Click Restoration Failures
Updated on 2025-08-01 GMT+08:00

Troubleshooting Agent One-Click Restoration Failures

Symptom

After you click Restore Agent Configurations, the Agent status is still Configuration error.

Constraints

The restoration method in this section only supports new Agent version. If your Agent is of an earlier version, you are advised to upgrade it to the new version.

Run the following command to check the current Agent version:

if [[ -f /usr/local/uniagent/extension/install/telescope/bin/telescope ]]; then /usr/local/uniagent/extension/install/telescope/bin/telescope -v; elif [[ -f /usr/local/telescope/bin/telescope ]]; then echo "old agent"; else echo 0; fi
  • If old agent is displayed, the early version of the Agent is used.
  • If a version is returned, the new version of the Agent is used.
  • If 0 is returned, the Agent is not installed.

Possible Causes

The following may cause this issue:

  1. DNS configurations
  2. IAM agency quota
  3. User permissions

Procedure

  1. Check DNS configurations.

    1. Log in to the management console.
    2. Under Compute, select Elastic Cloud Server.
    3. Click the name of the ECS.

      The ECS details page is displayed.

    4. Click the VPC name.

      The VPC console is displayed.

    5. In the VPC list, click the VPC name.
    6. On the Subnets page, check whether the DNS server addresses of the ECS are correct.

      For details about how to configure DNS server addresses for different regions, see Modifying the DNS Server Address and Adding Security Group Rules.

      Figure 1 DNS server address

  2. Check IAM agency quota.

    1. Log in to the management console.
    2. In the service list, select Identity and Access Management.
    3. On the IAM console, choose Agencies.
    4. Check the agency quota.

      Check whether there is the agency: CESAgentAutoConfigAgency.

      If there is no such an agency and the quota has been used up, delete unnecessary agencies and then perform one-click Agent restoration.

  3. Check user permissions.

    1. Log in to the management console.
    2. In the service list, select Identity and Access Management.
    3. In the navigation pane, click User Groups.
    4. Locate your user group and click Assign Permissions in the Operation column.
    5. To install the Agent, you must have the following permissions:
      • Global: Security Administrator
      • Region: ECS CommonOperationsr, or BMS CommonOperations and CES Administrator, or CES FullAccess
        Figure 2 Permissions required for installing the Agent