Help Center> Cloud Data Migration> FAQs> Troubleshooting> What Should I Do If a Job Exported from a Cluster Fails to Be Imported to Another Cluster?
Updated on 2023-06-21 GMT+08:00

What Should I Do If a Job Exported from a Cluster Fails to Be Imported to Another Cluster?

Symptom

When a job is exported from a CDM cluster of version 2.6.0 to a CDM cluster of version 2.8.6.1, an error message shown in the following figure is displayed.

Possible Cause

  1. Some parameters of the two clusters are incompatible. Check the throttlingConfig.concurrentSubJobs parameter (number of concurrent subjobs, which is unavailable in the new cluster) in the JSON file exported from the old cluster.

  1. Delete the following configuration item from the exported JSON file and import the job again to the new cluster again. The import is successful.
    {
    "name":"throttlingConfig.concurrentSubJobs",
    "value":"10"
    },
    

Solution

Delete the "name":"throttlingConfig.concurrentSubJobs" configuration item from the exported JSON file and import the JSON file again.

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