Help Center> Cloud Data Migration> FAQs> Troubleshooting> What Should I Do If Destination Fields Are Not Displayed When Auto Table Creation Is Enabled in the Destination Job Configuration?
Updated on 2023-06-21 GMT+08:00

What Should I Do If Destination Fields Are Not Displayed When Auto Table Creation Is Enabled in the Destination Job Configuration?

Symptom

In a job for migrating data from SQL Server to DWS, auto table creation is enabled in the destination job configuration, but destination fields are not displayed on the Map Field page.

Possible Cause

  1. The following error message is displayed in the backend log: org.postgresql.util.PSQLException: ERROR: relation "table name" does not exist.

  2. The error may be caused by the sandbox enabled for the CDM cluster, but the error persists after the sandbox is disabled and the CDM cluster is restarted.
  3. The name of the table in the source database contain only lowercase letters, but the name of the table to be migrated contains uppercase letters. Ensure that the name of the table to be migrated is consist with that in the database, and this issue is rectified.

Solution

In the source job configuration, enter the name of the table to be migrated based on its real name in the database or search for and select the table name.

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