Help Center/ Cloud Container Engine/ FAQs/ Workload/ Workload Exception Troubleshooting/ What Should I Do If There Is an Init Container Startup Failure in a Workload?
Updated on 2026-06-26 GMT+08:00

What Should I Do If There Is an Init Container Startup Failure in a Workload?

Symptom

  • The pod status is Init:N/M.
  • The pod status is Init:Error.
  • The pod status is Init:CrashLoopBackOff.

Possible Cause

  • If the pod status is Init:N/M, it indicates that the pod has M init containers and N of them have been started, while the number of the init containers that have failed to start is M – N.
  • If the pod status is Init:Error, it indicates that the init containers in the pod have failed to start.
  • If the pod status is Init:CrashLoopBackOff, it indicates that the init containers in the pod have failed to start and are being repeatedly restarted.

Solution

  1. View the pod events and check whether the init containers that are not started in the pod are abnormal. For details, see Viewing Pod Events.
  2. View the logs of the init containers that have not been started in the pod and locate the fault based on the logs. For details, see Viewing Container Logs.
  3. Check the pod configuration and check whether the configuration of the init containers that have not been started is proper. For details, see Viewing Pod Configurations. For details about the init containers, see Debug Init Containers.