Help Center/ Cloud Bastion Host/ FAQs/ Troubleshooting/ CBH Managed Resource Login Failures/ Why Am I Seeing User Creation Failure Message When Accessing a Windows Application Publishing Server?
Updated on 2024-12-03 GMT+08:00

Why Am I Seeing User Creation Failure Message When Accessing a Windows Application Publishing Server?

Symptoms

When an O&M engineer attempted to log in to a published Windows application, an error message is displayed indicating that the login denied and the user failed to be created.

Possible Causes

  • Cause 1: The version of RemoteAppProxy installed on the application publishing server is too low and needs to be upgraded.
  • Cause 2: The maximum length of the shadow account username to be created is longer than what the server account allows.

Solution

  • Solution 1: Upgrade RemoteAppProxy installed on the application publishing server to 1.1.8.0 or later.
  • Solution 2: Log in to the application publishing server, open the C:\DevOpsTools\RemoteAPPProxy\Application.ini file, and change the value of max_user_length (20 by default) to the maximum length of the shadow account username supported by the server, for example, 15.

    If you do not want to upgrade RemoteAppProxy, log in to the application publishing server, open the C:\DevOpsTools\RemoteAPPProxy\Application.ini file, and disable the shadow account by setting use_shadow_user to 0.

    The parameter indicating whether to use the shadow account mode is as follows:

    • 1: enabled.
    • 0: disabled.