Updated on 2024-04-24 GMT+08:00

Why Does FTP/SFTP Remote Backup Fail?

Symptoms

  • FTP/SFTP remote backup is configured in the CBH system. An error message is displayed, indicating that the server password or network connection is incorrect and the remote backup cannot be started.
  • When you back up logs of a specific day, the system displays a message indicating that the backup is being performed, but the remote server does not receive the backup file.

Possible Causes

Cause 1: The username or password configured in the CBH system for logging in to the FTP/SFTP server is incorrect.

Cause 2: The network connection between the CBH system and the FTP/SFTP server is interrupted.

Cause 3: The FTP/SFTP server restricts user directory upload.

Cause 4: A large number of O&M logs are generated on that specific day. The backup transmission rate is low and the backup takes a long time to complete. As a result, backup files cannot be displayed on the remote server immediately.

Solutions

Solution to cause 1
  • Log in to the ECS management console, log in to a Linux host using VNC, log in to the FTP/SFTP server from the Linux host, and verify the server username and password. After verifying the username and password, reconfigure the remote backup username and password of the FTP/SFTP server and try to back up data.

Solution to cause 2

  • Log in to the CBH system and check the network connection between the CBH system and the FTP/SFTP server by network diagnosis.
    • If the network connection is normal, check other possible causes.
    • If the network connection is abnormal, check whether port 22 is enabled in the security group of the CBH instance and FTP/SFTP server. Check whether port 22 is enabled and whether the public IP address (EIP) of the CBH instance is allowed in the ACL rule of the FTP/SFTP server.

Solution to cause 3

  • Grant the upload permission on the user directory.
  • Log in to the CBH system, choose System > Data Maintenance > Log Backup, and reconfigure the storage path of the FTP/SFTP server.

    If the storage path is left blank, the backup content is stored in the home directory of the FTP/SFTP server, for example, the absolute path /home/user name. The path must start with a period (.). For example, if the path is ./test/abc, the absolute path is /home/user name/test/abc.

Solution to cause 4

  • View the backup file on the server the day after the backup starts.

If the problem persists, click Service Tickets in the upper right corner of the management console and submit a service ticket.

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