Help Center> Cloud Bastion Host> FAQs> Troubleshooting> Maintenance Issues> Why Text Cannot Be Copied When I Perform O&M Through a Web Browser?
Updated on 2022-11-30 GMT+08:00

Why Text Cannot Be Copied When I Perform O&M Through a Web Browser?

Text Cannot Be Copied or Pasted

Symptoms

You cannot use the copy and paste functions on the Host Operation session page.

Possible Causes

  • Cause 1: The permission for clipboard is not enabled for you or the host resource.
  • Cause 2: The clipboard program on the Windows host is faulty or suspended.

Solution

  • Solution to cause 1
    The clipboard function of the host must be enabled, and you must have been granted the permission to use the clipboard.
  • Solution to cause 2

    Reload or restart the clipboard program rdpclip.exe on the Windows host.

Unable to Copy Extra-long Text to a Windows Host

Symptoms

When you attempt to copy a text from a local computer to a managed Windows host, a message is displayed indicating that the text is too long and the file management function is recommended.

Possible Causes

Text with more than 80,000 characters cannot be copied or pasted from a local PC to a managed host in the CBH system.

Solution

  1. Enable the file management function and obtain file management permission.

    1. To enable the file management function on a host resource, see Modifying Host Configuration.
    2. To obtain the file management permission, see Modifying an ACL Rule or ACL Ticket.

  2. Copy your text file to a local disk and upload the file to the Personal Netdisk. Go to the G:\ directory on the Windows host and obtain the text content in the file.

For more details about copy/paste, see How Do I Use Shortcut Keys to Copy/Past Text During Web-based O&M?

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