What Should I Do If the App Authentication Information Is Incorrect?
You may encounter the following errors related to app authentication information:
- Incorrect app authentication information: app not found, appkey xxx
- Incorrect app authentication information: verify signature fail, canonicalRequest
- Incorrect app authentication information: signature expired
Incorrect app authentication information: app not found, appkey xxx
{ "error_msg": "Incorrect app authentication information: app not found, appkey 01177c425f71487ea362ba84dc4abe5e1", "error_code": "APIG.0303", "request_id": "a5322eb89048eb41d705491a76a05aca" }
Possible Causes
The AppKey is incorrect.
Solution
- In the navigation pane of the APIG console, choose API Management > Credentials.
- Click the corresponding credential name to go to the details page.
- Check the Key and reconfigure the AppKey.
Incorrect app authentication information: verify signature fail, canonicalRequest
{ "error_msg": "Incorrect app authentication information: verify signature fail, canonicalRequest:GET|/test/||host:d7da6fe436fb48f2af3c5c2e5b203df7.example.com|x-sdk-date:20230527T015431Z||host;x-sdk-date|e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855", "error_code": "APIG.0303", "request_id": "cb141a91c945e68950a14a8eff5d62dc" }
Possible Causes
The signature algorithm is incorrect, and the signature calculated by the client is different from that calculated by APIG.
Solution
For details, see Incorrect IAM authentication information: verify aksk signature fail.
Incorrect app authentication information: signature expired
{ "error_msg": "Incorrect app authentication information: signature expired, signature time:20230527T000431Z,server time:20230527T020608Z", "error_code": "APIG.0303", "request_id": "fd6530a01c09807640189e65e837b8ad" }
Possible Causes
The difference between the client's signature timestamp x-sdk-date and the APIG server's time exceeds 15 minutes.
Solution
Check whether the time on the client is correct.
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