Help Center/ GeminiDB/ API Reference/ API v3/ Instances/ Configuring an Automatic Scale-up Policy
Updated on 2026-09-22 GMT+08:00

Configuring an Automatic Scale-up Policy

Function

This API is used to configure an automatic scale-up policy.

Constraints

  • This API supports the following instances:
    • GeminiDB Cassandra
    • GeminiDB Redis
  • This API supports both pay-per-use and yearly/monthly instances.
  • For yearly/monthly instances, the system bills new storage space automatically by default.
  • Autoscaling is available only when your account balance is sufficient.
  • If the instance status is not normal, autoscaling of storage space cannot be configured.

Authorization Information

Each account has permissions to call all APIs, but IAM users must have the required permissions specifically assigned.

  • If you are using role/policy-based authorization, see the required permissions in Permissions and Supported Actions.
  • If you are using identity policy-based authorization, the following identity policy-based permissions are required.

    Action

    Access Level

    Resource Type (*: required)

    Condition Key

    Alias

    Dependencies

    gaussdbfornosql:instance:setAutoExtendVolumePolicy

    Write

    -

    -

    nosql:instance:modifyStorageSize

    -

URI

PUT /v3/{project_id}/instances/disk-auto-expansion

Table 1 URI parameters

Parameter

Mandatory

Type

Description

project_id

Yes

String

Definition

Project ID of a tenant in a region. To obtain this value, see Obtaining a Project ID.

Constraints

N/A

Range

The value contains 32 characters. Only letters and digits are allowed.

Default Value

N/A

Request Parameters

Table 2 Request header parameters

Parameter

Mandatory

Type

Description

X-Auth-Token

Yes

String

Definition

User token

You can obtain the token by calling the IAM API by following Obtaining a User Token Through Password Authentication.

Constraints

N/A

Range

N/A

Default Value

N/A

Table 3 Request body parameters

Parameter

Mandatory

Type

Description

instance_ids

Yes

Array of strings

Definition

IDs of instances for which storage autoscaling is enabled. To obtain the value, call the Querying Instances and Details API.

Constraints

A maximum of 50 instances are supported.

switch_option

No

String

Definition

Whether autoscaling is enabled

Constraints

N/A

Range

  • on: Storage autoscaling is enabled.
  • off: Storage autoscaling is disabled.

Default Value

on

policy

No

diskAutoExpansionPolicy object

Definition

Autoscaling policies for storage space.

Constraints

N/A

Table 4 diskAutoExpansionPolicy

Parameter

Mandatory

Type

Description

threshold

No

Integer

Definition

Threshold for triggering autoscaling, in percentage.

Constraints

N/A

Range

  • The value of a GeminiDB Cassandra instance can be 80, 85, or 90.
  • The value of a GeminiDB Redis instance can be 60, 65, 70, 75, 80, 85, or 90.

Default Value

  • The default threshold of a GeminiDB Cassandra instance is 90, which indicates autoscaling is enabled when the used storage exceeds 90% of total storage or the available storage is less than 10 GB.
  • The default threshold of a GeminiDB Redis instance is 80, which indicates autoscaling is enabled when the used storage exceeds 80% of total storage.

step

No

Integer

Definition

Autoscaling step (s%).

Constraints

  • GeminiDB Cassandra
    • After autoscaling is enabled, storage space will increase by s% automatically.
  • GeminiDB Redis
    • When the storage usage is greater than 98%: If the total storage is less than 600 GB, the storage usage after autoscaling (used storage space/total storage space) will be less than 85%. If the total storage is greater than or equal to 600 GB, the system automatically scales up the storage space by over 90 GB.
NOTE:
  • GeminiDB Cassandra instances
    • If the autoscaling step is not a multiple of 10, round it up.
    • The value after the decimal point is rounded. The minimum step is 100 GB by default.
  • GeminiDB Redis instances
    • The value after the decimal point is rounded. The minimum step is 1 GB by default.
  • If there is insufficient balance in your account, storage space may fail to be scaled up for yearly/monthly instances.

Range

  • GeminiDB Cassandra instances
    • 10, 15, and 20 are supported.
  • GeminiDB Redis instances
    • 10, 15, and 20 are supported.

Default Value

  • GeminiDB Cassandra
    • 10
  • GeminiDB Redis
    • 20

size

No

Integer

Definition

Storage limit in GB that autoscaling can increase storage space to.

Constraints

  • GeminiDB Cassandra instances
  • GeminiDB Redis instances

Range

N/A

Default Value

N/A

Response Parameters

Status code: 200

Table 5 Response body parameters

Parameter

Type

Description

error_results

ErrorResult objects

Definition

Instances for which a storage autoscaling policy fails to be set

Table 6 ErrorResult

Parameter

Type

Description

instance_id

String

Definition

Instance ID

Range

N/A

error_message

String

Definition

Error message

Range

N/A

Example Requests

  • Enabling autoscaling for storage space (Set threshold to 90, step to 10, and size to 600.)
    PUT https://{Endpoint}/v3/619d3e78f61b4be68bc5aa0b59edcf7b/instances/disk-auto-expansion 
    
    { 
      "instance_ids" : [ "93e4b3eda14349b1b870f72829bc3b9bin06" ], 
      "switch_option": "on",
      "policy" : { 
        "threshold" : 90, 
        "step" : 10, 
        "size" : 600 
      } 
    }
  • Disabling the autoscaling policy of storage space
    PUT https://{Endpoint}/v3/619d3e78f61b4be68bc5aa0b59edcf7b/instances/disk-auto-expansion 
    
    {
        "instance_ids": [ "93e4b3eda14349b1b870f72829bc3b9bin06" ],
        "switch_option": "off"
    }

Example Responses

Status code: 200

Success

{    "error_results" : [{
        "instance_id" : "93e4b3eda14349b1b870f72829bc3b9bin06",
        "error_message": "xasdasdas"
  }]
}

Status Codes

For details, see Status Codes.

Error Codes

For details, see Error Codes.