Help Center> Distributed Message Service> API Reference> FAQ> Why Is the Message "Connect IAM Timeout" Displayed When I Attempt to Access DMS?
Updated on 2023-09-04 GMT+08:00

Why Is the Message "Connect IAM Timeout" Displayed When I Attempt to Access DMS?

Symptom

An error message "Connect IAM Timeout" is displayed when I attempt to use the API to access DMS.

Get quota fail: 401
{"message": "Connect IAM Timeout", "request_id": 
"5ACB6B21-DAF6-47C8-B7A4-45A7BDC57FC6"}

Possible Cause

The AK/SK pair is deleted on the web-based DMS console.

Troubleshooting Method

  1. Log in to the management console.
  2. Click the username and select My Credential from the drop-down list.
  3. Click Access Keys.
  4. Click Add Access Key.
  5. Enter Login Password and Verification Code and click OK. Download the access key and keep it secure.
  6. Use the new AK/SK pair to access DMS.