Help Center/ Relational Database Service/ User Guide (Ally Region)/ FAQs/ Database Storage/ What Should I Do If My Data Exceeds the Available Storage of an RDS for MySQL Instance?
Updated on 2026-04-24 GMT+08:00

What Should I Do If My Data Exceeds the Available Storage of an RDS for MySQL Instance?

Symptom

There is not enough storage available for an RDS instance and the instance becomes read-only, so applications cannot write any data to the instance.

Causes

  • Increased workload data
  • Too much data being stored
  • Excessive binlogs generated by a high volume of transactions and write operations
  • Too many temporary files generated due to a large number of sorting queries executed by applications

Solution

  1. For insufficient storage caused by increased workload data, scale up storage space.

    If the original storage has reached the maximum, upgrade the specifications first.

  2. If too much data is stored, delete unnecessary historical data.
    1. If the instance becomes read-only, you need to contact technical support to disable the read-only status first.
    2. To free up space, you can run OPTIMIZE on tables with a high fragmentation rate during off-peak hours.

      To clear an entire table, run DROP or TRUNCATE. To delete only part of table data, run DELETE. However, after performing DELETE, you need to run OPTIMIZE TABLE to reclaim the released storage space.

  3. If binlogs occupy too much space, clean up local binlogs.
  4. If temporary files generated by sorting queries occupy too much storage space, optimize your SQL queries.