Updated on 2026-09-03 GMT+08:00

Disabling Kibana/Dashboards Public Network Access

Function

This API is used to disable public Kibana/Dashboards access for an Elasticsearch/OpenSearch cluster.

After public Kibana/Dashboards access is disabled and re-enabled, the public address of Kibana may change. Proceed with caution.

Calling Method

For details, see Calling APIs.

URI

PUT /v1.0/{project_id}/clusters/{cluster_id}/publickibana/close

Table 1 Path Parameters

Parameter

Mandatory

Type

Description

project_id

Yes

String

Definition

Project ID. For details about how to obtain the project ID and name, see Obtaining the Project ID and Name.

Constraints

N/A

Range

Project ID of an account. The value contains 32 characters, consisting of lowercase letters and digits.

Default Value

N/A

cluster_id

Yes

String

Definition

ID of the cluster whose Kibana/Dashboards public network access you want to disable. For details about how to obtain the cluster ID, see Obtaining the Cluster ID.

Constraints

N/A

Range

The value is a UUID containing 36 characters.

Default Value

N/A

Request Parameters

Table 2 Request body parameters

Parameter

Mandatory

Type

Description

eip_size

No

Integer

Definition:

The bandwidth size in Mbit/s.

Constraints:

N/A

Value range:

1–200.

Default value:

N/A

elb_white_list

No

StartKibanaPublicReqElbWhitelist object

Definition:

Public network access whitelist for Kibana/Dashboards.

Constraints:

N/A.

Table 3 StartKibanaPublicReqElbWhitelist

Parameter

Mandatory

Type

Description

enable_white_list

Yes

Boolean

Definition:

Whether to enable the whitelist used for public network access control for Kibana/Dashboards.

Constraints:

N/A

Value range:

  • true: The whitelist is enabled.

  • false: The whitelist is disabled.

Default value:

N/A

white_list

Yes

String

Definition

Whitelist for Kibana/Dashboards public access control. Add the IP addresses or CIDR blocks to be whitelisted, separated by commas (,). Valid examples: 192.168.1.1,10.0.0.0/24.

Constraints

The following are not supported: 0.0.0.0,x.x.x.x/0, non-standard formats such as 192.168.1, or duplicate entries.

Range

Valid CIDR blocks or IP addresses.

Default Value

N/A

Response Parameters

Status code: 200

Request succeeded.

None

Example Requests

Disable public network access to Kibana or OpenSearch Dashboards.

PUT https://{Endpoint}/v1.0/{project_id}/clusters/4f3deec3-efa8-4598-bf91-560aad1377a3/publickibana/close

Example Responses

None

Status Codes

Status Code

Description

200

Request succeeded.

400

Invalid request.

Modify the request before retry.

409

The request could not be completed due to a conflict with the current state of the resource.

The resource that the client attempts to create already exists, or the update request fails to be processed because of a conflict.

412

The server did not meet one of the preconditions contained in the request.

Error Codes

See Error Codes.