Help Center> Server Migration Service> User Guide(ME-Abu Dhabi Region)> FAQs> OS Compatibility and Migration Restrictions> How Do I Resolve Error "VSS not installed on the source server"?
Updated on 2024-03-15 GMT+08:00

How Do I Resolve Error "VSS not installed on the source server"?

Symptom

After the Agent was started, a source server running Windows did not pass the migration feasibility check, and error message "SMS.6533 VSS not installed on the source server" was displayed on the SMS console.

Possible Causes

The possible causes are as follows:

  1. The VSS service is not installed on the source server.
  2. The VSS service is disabled on the source server.

Solution

  1. Open the Task Manager and check whether the VSS service is there. If it is, go to 2. If it is not, go to 3.
    Figure 1 Checking whether the VSS service exists
  2. Modify the configuration file to disable I/O monitoring.

    If you do not need to synchronize data, you can modify the configuration file to disable I/O monitoring.

    In the Agent installation directory config, change the value of enablesync to False in the g-property.cfg file, and then restart the Agent.

    Figure 2 Modifying the g-property.cfg file
  3. Check VSS status. If its status is Stopped, right-click the service and choose Open Services from the shortcut menu. Locate and right-click Volume Shadow Copy, and choose Properties from the shortcut menu. On the displayed Volume Shadow Copy Properties window, change the Startup type to Manual. Click OK.
    Figure 3 Changing the startup mode of VSS
  4. Go back to the Task Manager window, locate and right-click VSS, and choose Start from the shortcut menu.
    Figure 4 Starting VSS
  5. Log in to the SMS console, locate the migration task, and in the Operation column, choose More > Delete.

    After the deletion is complete, restart the Agent.