Help Center> Server Migration Service> User Guide(ME-Abu Dhabi Region)> FAQs> Disk Management> How Do I Resolve Error "Disk info in source server has changed, task fail, please delete the task and then restart the agent"?
Updated on 2024-03-15 GMT+08:00

How Do I Resolve Error "Disk info in source server has changed, task fail, please delete the task and then restart the agent"?

Symptom

When you started the migration, you got the error message "SMS.0515 Disk info in source server has changed, task fail, please delete the task and then restart the agent."

Possible Causes

The Agent collects information about the disks on the source server every two hours. This error will occur if the source server disks are changed during the period from the last collection to the start of migration. Possible changes in source server disks include:

  • Disks or partitions were attached or detached to the source server.
  • The capacity of a source partition may have been expanded, and now the target disk space is insufficient.
  • A large amount of data was written to a source partition, and now the target partition space is insufficient.
  • The file system type of the source partition was changed.

Solution

  1. Log in to the management console.
  2. Click Service List. Under Migration, click Server Migration Service.

    The SMS console is displayed.

  3. In the navigation pane on the left, choose Task Management.

    Locate the task to be deleted, and in the Operation column, choose More > Delete.

  4. Log in to the source server and restart the Agent. The Agent automatically reports changed source disk information to SMS.
  5. Create a migration task for the source server again and start the task. For details, see "Creating and Starting a Migration Task."