Help Center> Anti-DDoS Service> FAQs> AAD FAQs> Faults> Why Is Error 504 Displayed When I Access a Website After AAD Is Configured?
Updated on 2023-03-23 GMT+08:00

Why Is Error 504 Displayed When I Access a Website After AAD Is Configured?

Symptom

When a user visits a website with AAD configured, error code 504 is displayed after a long period of wait time.

Possible Causes

It takes a long period of time for the website to process some POST requests, and the time required exceeds the connection timeout threshold of AAD. As a result, AAD proactively drops the connection.

  • The default TCP connection timeout is 900s.
  • The default HTTP/WebSocket or HTTPS/WebSockets connection timeout is 120s.

Solution

It is recommended that you deploy a heartbeat mechanism to process time-consuming tasks at the application layer. This mechanism helps keep connections alive during the wait time.

For occasional time-consuming requests, you can send them directly to cloud servers by bypassing AAD.

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