ALM-29005 Number of JDBC Connections to Impalad Exceeds the Threshold
Alarm Description
The system checks the number of client connections to the Impalad node every 30 seconds. This alarm is generated when the number of client connections exceeds the customized threshold (60 by default).
This alarm is automatically cleared when the number of client connections is less than the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
29005 |
Major |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
|
Additional Information |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
New client connections may be blocked or even fail.
Possible Causes
Too many connections have been established with the Impala server or the threshold is too small.
Handling Procedure
- On FusionInsight Manager, choose O&M > Alarm > Thresholds > Impala > Connections > Number of JDBC Connections to Impalad Process to check the configured threshold.
- Check the number of JDBC applications connected to Impalad and stop idle applications. Check whether the alarm is automatically cleared.
- If yes, no further action is required.
- If no, go to 3 to change the number of concurrent client connections.
- On FusionInsight Manager, choose Cluster > Impala > Configurations > All Configurations > Impalad > Customization. Add the customized parameter --fe_service_threads. The default value of this parameter is 64. Change the value as required and click Save.
- After the query tasks on all clients are complete, click the Instance tab. Select all Impalad instances, and restart them.
The service will become unavailable when all instances are restarted. If a single instance is restarted, the tasks that are being executed on that instance will fail and the service will become available.
- After the restart is complete, check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Impala for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
After the fault that triggers the alarm is rectified, the alarm is automatically cleared.
Related Information
None
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