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How Can I Fix Grayed Out Copy and Paste Options?
Updated on 2022-07-15 GMT+08:00
How Can I Fix Grayed Out Copy and Paste Options?
Symptom
After remotely logging in to a Windows ECS, I cannot copy or paste content and find that the Paste option grayed out.
Possible Causes
- Local drive is not mapped.
- An error has occurred in the rdpclip.exe process.
- Data cannot be copied and pasted between the ECS and the local server.
Solution
- The local drive is not mapped. Figure 1 uses local drive C and drive D as an example.
- Open the Run dialog box, enter mstsc, and click OK to start Remote Desktop Connection.
- Click the Local Resources tab and select Clipboard in the Local devices and resources pane. Click More and select the drives you want to use in the remote session.
- Click OK and check whether the copy and paste options work.
- An error has occurred in the rdpclip.exe process.
- Enable remote desktop connection, start Windows Task Manager, and stop the rdpclip.exe process on the Processes tab page.
Figure 2 Ending the rdpclip.exe process
- Open the Run dialog box, enter rdpclip.exe, and click OK to restart it.
Figure 3 Starting the rdpclip.exe process
- Check whether the copy and paste options work.
- Enable remote desktop connection, start Windows Task Manager, and stop the rdpclip.exe process on the Processes tab page.
- Data cannot be copied and pasted between the ECS and the local server.
- Choose Start > Run. In the Run dialog box, enter gpedit.msc and click OK to start Local Group Policy Editor.
- Choose Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection.
- Set Do not allow Clipboard redirection, Do not allow COM port redirection, Do not allow drive redirection, and Do not allow LPT port redirection to Disabled.
Figure 4 Device and resource redirection
- Restart the ECS and check whether the copy and paste options work.
Parent topic: Windows ECS Issues
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