ALM-50212 Accumulated Old-Generation GC Duration of the FE Process Exceeds the Threshold
Alarm Description
The system checks the accumulated old-generation GC duration of the FE process every 30 seconds. This alarm is generated when the accumulated GC duration exceeds the threshold (3000 ms by default).
This alarm is cleared when the system detects that the accumulated old-generation GC duration of the FE process is less than the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
50212 |
Major |
Quality of service |
Doris |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Detail |
Specifies the alarm triggering condition. |
Impact on the System
A long GC duration of the FE process may interrupt the services.
Possible Causes
The heap memory of the FE process is overused or inappropriately allocated, causing frequent occurrence of the GC process.
Handling Procedure
Check the GC duration.
- On FusionInsight Manager, choose O&M > Alarm > Alarms. In the alarm list, view the role name and obtain the IP address of the instance in Location of the alarm whose ID is 50212.
- Choose Cluster > Services > Doris > Instances, click the FE instance for which the alarm is generated, and click the Chart tab of the instance.
- Choose Cluster > Services > Doris > Configurations > All Configurations > FE(Role) > JVM, and increase the value of -Xmx in FE_GC_OPTS. The default value is 8G.
- If this alarm is occasionally generated, increase the value by 0.5 times. If this alarm is frequently generated, double the value.
- In the case of large service volume and high service concurrency, you are advised to add instances.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 5.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Doris for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot