ALM-45615 CDL Service Unavailable
Alarm Description
The system checks the CDL health status every 60 seconds. This alarm is generated when the CDL health status is DOWN. This alarm is cleared when the system detects that the CDL health status is UP.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
45615 |
Critical |
Quality of service |
CDL |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
Impact on the System
The CDL service is abnormal. You cannot use FusionInsight Manager to perform cluster operations on the CDL service. The CDL service function is unavailable.
Possible Causes
All CDLService or CDLConnector instances of the CDL service are abnormal, and the Kafka service is unavailable.
Handling Procedure
Check whether the Kafka service on which the CDL service depends is abnormal.
- On FusionInsight Manager, choose O&M > Alarm > Alarms.
- In the alarm list, check whether ALM-38000 Kafka Service Unavailable exists.
- Handle the alarm by referring to "ALM-38000 Kafka Service Unavailable".
- After the alarm is cleared, wait a few minutes and check whether the alarm HetuServer Service Unavailable is cleared.
- If yes, no further action is required.
- If no, go to 5.
Check whether CDL instances are faulty.
- On FusionInsight Manager, choose Cluster > Name of the desired cluster > Service > CDL > Instance.
- Check whether all CDLService and CDLConnector instances are faulty.
Collect the fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select CDL for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
After the service is restored, the system automatically clears the alarm.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot