ALM-45592 IoTDBServer RPC Execution Duration Exceeds the Threshold
Alarm Description
The system checks the RPC execution duration of the IoTDBServer process every 60 seconds. This alarm is generated when the execution duration exceeds the threshold. This alarm is cleared when the RPC execution time of the IoTDBServer process is less than the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
45592 |
Major |
Quality of service |
IoTDB |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
|
Additional Information |
Trigger Condition |
Specifies the alarm triggering condition. |
Impact on the System
Running performance of the IoTDBServer process is affected.
Possible Causes
The processing duration of an IoTDBServer RPC request exceeds the threshold. Logs need to be further analyzed to locate the cause.
Handling Procedure
Collect fault information.
- Log in to FusionInsight Manager, choose O&M > Alarm > Alarms. In the real-time alarm list, click in front of this alarm and view the role name and instance IP address in Location.
- Choose O&M > Log > Download.
- Expand the Service drop-down list, select IoTDB for the target cluster, and click OK.
- Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the host queried in 1, and click OK.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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