ALM-43614 Time Spent on a GraphBase Path Query Request Exceeds the Threshold
Alarm Description
The system checks the status of GraphBase service every 30 seconds. This alarm is generated when the time Spent on a path query request on the GraphBase client from the GraphServer node exceeds the configured threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
43614 |
Major |
Quality of service |
GraphBase |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- If the requested content is too large or the request is frequently sent, the system is delayed. As a result, the communication between services may be abnormal.
- The GraphBase service may be unavailable.
Possible Causes
- The content requested by the client is too large or the request is frequently sent.
- The threshold is configured too low.
Handling Procedure
Check the time spent on a real-time path query request on the GraphServer node.
- On the FusionInsight Manager homepage, choose O&M > Alarm > Threshold Configuration > Name of desired the cluster > GraphBase to view the threshold of Response Time for a Path Query on GraphServer.
- On FusionInsight Manager, choose O&M > Alarm > Alarms and select the alarm whose ID is 43614. Check the role name and the IP address of the host where the alarm is generated in Location.
- On the FusionInsight Manager homepage, choose Cluster > Name of the desired cluster > Service > GraphBase > Instance. Click the GraphServer where the alarm is reported. On the dashboard page that is displayed, expand the drop-down list box in the upper right corner of the graph area, choose Customize > Response Time for a Path Query on GraphServer, and click OK to check whether the query time of the current path exceeds the threshold.
- On the FusionInsight Manager homepage, choose O&M > Alarm > Threshold Configuration > Name of desired cluster > GraphBase to update the threshold of Response Time for a Path Query on GraphServer.
- Wait for one minute and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
- Stop sending any requests for creating, deleting, updating, or querying relationships.
Wait for one minute and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 7.
Collect the fault information.
- On the FusionInsight Manager homepage, choose O&M > Log > Download.
- Expand the Service drop-down list, and select GraphBase for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None.
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