ALM-43608 Floating IP Address of GraphBase Is Faulty
Alarm Description
The system checks the floating IP address of GraphBase every 30 seconds. This alarm is generated when the floating IP address of GraphBase is abnormal during HA health check.
This alarm is cleared when the floating IP address of GraphBase becomes normal during HA health check.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
43608 |
Major |
Error handling |
GraphBase |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- If the GraphBase floating IP address is abnormal, users cannot log in to and use FusionInsight Manager.
- The active and standby LoadBalancers of GraphBase may be switched over.
- The GraphBase service may be unavailable.
Possible Causes
The floating IP address is abnormal.
Handling Procedure
Check whether the node where GraphBase is deployed is normal.
- On the FusionInsight Manager homepage, choose Cluster > Name of the desired cluster > Service > GraphBase > Configuration > All Configurations, and search for loadbalancer.floatip.
- Check whether the value of loadbalancer.floatip can be pinged.
- Wait for 5 minutes, and check whether this alarm is cleared.
- If yes, no further action is required.
- If no, go to 4.
- On FusionInsight Manager, select the alarm whose ID is 43608, and view the IP address of the instance in location information.
- Log in to the node for which the alarm is generated as user root.
- Go to the ${BIGDATA_HOME}/FusionInsight_GraphBase_*/install/FusionInsight-GraphBase-*/miner/ha/module/hacom/script/ directory and run the sh status_ha.sh script to check whether the floating IP address of the active Manager is normal. Specifically, check whether the following information is displayed in the line where ResName of the active management node is floatip:
The following is an example:
floatip Normal Normal Single_active
- Contact the network administrator to check whether the network is faulty.
- Wait for 5 minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 9.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select GraphBase for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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