Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-33012 Containers' ZooKeeper Client Is Disconnected
Updated on 2024-11-29 GMT+08:00

ALM-33012 Containers' ZooKeeper Client Is Disconnected

Alarm Description

Multiple modules in the FusionInsight RTD cluster contain the ZooKeeper client. This alarm is generated when the ZooKeeper client is disconnected from the ZooKeeper server.

This alarm is automatically cleared when the connection is restored.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

33012

Minor

Communications

Containers

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

ClientLocation

Specifies the location of the ZooKeeper client.

ServerAddress

Specifies the ZooKeeper server address.

Impact on the System

If the ZooKeeper client is disconnected, ZooKeeper-dependent functions in the FusionInsight RTD cluster may be unavailable.

Possible Causes

  • ZooKeeper is faulty.
  • The ZooKeeper client fails to be connected due to a network fault.

Handling Procedure

Check whether ZooKeeper is faulty.

  1. On FusionInsight Manager, choose Cluster > Services > ZooKeeper and check whether the ZooKeeper service is running properly.

    • If yes, go to 3.
    • If no, go to 2.

  2. Click More and select Restart Service. In the dialog box that is displayed, enter the password to restart ZooKeeper. After the restart is successful, check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 3.

Check whether the ZooKeeper client fails to be connected due to a network fault.

  1. Check whether the network between the client and the server is normal and the time is consistent based on the client location and server address in the alarm information.

    • If yes, go to 5.
    • If no, go to 4.

  2. Restore the network and adjust the time to ensure that the time difference between the client and server is less than 5 minutes (ignore the time difference for a normal cluster). Wait 5 minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 5.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list and select Containers.
  3. Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the hosts to which the role belongs, and click OK.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.