Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-19018 HBase Compaction Queue Size Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-19018 HBase Compaction Queue Size Exceeds the Threshold

Alarm Description

The system checks the HBase compaction queue size every 30 seconds. This alarm is generated when the compaction queue size exceeds the alarm threshold (100 by default) for three consecutive times. This alarm is cleared when the compaction queue size is less than the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

19018

Minor

Quality of service

HBase

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Additional Information

Trigger Condition

Specifies the alarm triggering condition.

Impact on the System

Write pressure on the HBase node continues going up, and the disk I/O and CPU may be overloaded. Read and write requests are responded slowly or even time out.

Possible Causes

  • The number of HBase RegionServers is too small.
  • There are excessive regions on a single RegionServer of HBase.
  • The HBase RegionServer heap size is small.
  • Resources are insufficient.
  • Related parameters are not configured properly.

Handling Procedure

Check whether related parameters are properly configured.

  1. Log in to FusionInsight Manager and choose O&M > Alarm > Alarms. On the page that is displayed, check whether the alarm whose Alarm ID is 19008 or 19011 exists.

    • If yes, click View Help next to the alarm and rectify the fault by referring to the help document. Then, go to 3.
    • If no, go to 2.

  2. On FusionInsight Manager, choose Cluster, click the name of the desired cluster, and choose Services > HBase. On the page that is displayed, click the Configuration tab then the All Configurations sub-tab, search for hbase.hstore.compaction.min, hbase.hstore.compaction.max, hbase.regionserver.thread.compaction.small, and hbase.regionserver.thread.compaction.throttle, and set them to larger values.
  3. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 4.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select HBase for the target cluster.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.