Help Center/ MapReduce Service/ Component Operation Guide (LTS) (Ankara Region)/ Using CDL/ CDL FAQs/ What Should I Do If a CDL Data Synchronization Task Fails and the YARN Task Waits for More Than 10 Minutes Before Running Again?
Updated on 2024-11-29 GMT+08:00

What Should I Do If a CDL Data Synchronization Task Fails and the YARN Task Waits for More Than 10 Minutes Before Running Again?

Symptom

The CDL data synchronization task failed. The corresponding YARN task run again after more than 10 minutes. The following figure shows the running time of the YARN task.

Possible Cause

If a CDL data synchronization task fails, the corresponding YARN task automatically retries. If the YARN task cannot run again after 20 retries within 10 minutes, the task configuration or data is in error. In this case, the YARN task stops retrying and sleeps for 10 minutes. After that, the YARN task continues to retry.

Procedure

  1. Log in to FusionInsight Manager, choose Cluster > Services > Yarn, and click ResourceManager(Active) on the right of ResourceManager WebUI. The YARN web UI page is displayed.
  2. Search for the name of the CDL task for which the error is reported, locate the latest task running record, and click the task ID in the ID column. Click Logs, and then stdout. Rectify the fault based on the error information in the stdout log.
  3. On FusionInsight Manager, choose Cluster > Services > CDL. Click the hyperlink on the right of CDLService UI to go to the CDL web UI. In the row where the job is, choose More > Stop to stop the CDL task. After the task is stopped, click Start to restart the task.