Why Is the Private Key Pair Invisible After It Is Upgraded to an Account Key Pair When Logging in as a Federated User?
Symptom
After logging in as a federated user, some key pairs in the private key pair list are invisible after the account key pair is upgraded on the private key pair page.
Possible Causes
The user ID of the federated login account is a virtual ID and cannot be obtained in the upgrade scenario. Therefore, after the key pair is upgraded, the key pair in the original private key pair list is invisible.
Procedure
Before using a federated account, use the master account to upgrade the account key pair.
A private key pair is used to isolate resources based on the user ID of an account, and an account key pair is used to isolate resources based on the domain ID. Therefore, The recommended settings are as follows:
- |
Management account |
Federated authentication account |
Delegated account |
---|---|---|---|
Private key pair |
Not recommended |
Prohibited |
Prohibited |
Account key pair |
Recommended |
Recommended |
Recommended |
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