Help Center/ DataArts Studio/ FAQs/ Consultation and Billing/ What Should I Do If a User Cannot View Workspaces After I Have Assigned the Required Policy to the User?
Updated on 2024-11-05 GMT+08:00

What Should I Do If a User Cannot View Workspaces After I Have Assigned the Required Policy to the User?

Possible Causes

DataArts Studio assigns permissions through DAYU system roles and workspace roles. To ensure that the IAM user permissions are normal, the user group to which the IAM user belongs must be assigned the DAYU User or DAYU Administrator role on the IAM console. In addition, ensure that the IAM user with the DAYU User role has been assigned the corresponding role in the DataArts Studio workspace.

If you assign only the DAYU User system role but not a workspace role to a user, the user cannot access a workspace and an error message is displayed.

Solution

Check whether the user has been added to the workspace. If not, perform the following steps to add the user:

  1. Log in to the DataArts Studio console by following the instructions in Accessing the DataArts Studio Instance Console.
  2. On the Workspaces page, locate a workspace and click Edit in the Operation column.

    Figure 1 Workspace Information dialog box

  3. Click Add under Workspace Members. In the displayed Add Member dialog box, select Add User or Add Group, select a member account from the drop-down list, and select a role for it.

    Figure 2 Adding a member

  4. Click OK. You can view or modify the members and roles in the member list, or remove members from the workspace.