Help Center/ Server Migration Service/ User Guide(ME-Abu Dhabi Region)/ FAQs/ Disk Management/ How Do I Resolve Error "Insufficient disks on the Target ECS"?
Updated on 2024-03-15 GMT+08:00

How Do I Resolve Error "Insufficient disks on the Target ECS"?

Symptom

When you configure or launch the target server, you got a message "SMS.1311 Insufficient disks on the Target ECS."

Possible Causes

  • When configuring the target server, SMS checks whether the target server has the same number of disks as the source server. If you receive this error, check whether the number of disks on the target server is less than that on the source server, or whether any disks on the target server have been manually deleted or detached. If this is the case, perform the operations described in Solution for Inconsistent Number of Disks Between the Source and Target Servers.
  • After the Agent is started, any disk additions or deletions on the source server will make the Agent fail to identify the disk changes. If this is the case, perform the operations described in Solution for Disk Additions or Deletions on the Source Server.

Solution for Inconsistent Number of Disks Between the Source and Target Servers

  1. Click Service List. Under Migration, click Server Migration Service.
  2. The SMS console is displayed.
  3. In the navigation pane on the left, choose Servers.
  4. The server list is displayed.
  5. Locate the source server and choose More > Delete Target Configuration.
  6. Attach disks to the target server to ensure that the target server has at least as many disks as the source server.
  7. Go back to SMS console, locate the source server in the server list, and click Configure in the Target column to configure the target server. Then perform the migration again.

Solution for Disk Additions or Deletions on the Source Server

  1. Click Service List. Under Migration, click Server Migration Service.

    The SMS console is displayed.

  2. In the navigation pane on the left, choose Servers.

    The server list is displayed.

  3. Locate the source server, choose More > Delete This Server.
  4. Attach disks to the target server to ensure that the target server has at least as many disks as the source server.
  5. Go back to SMS console, locate the source server in the server list, and click Configure in the Target column to configure the target server. Then perform the migration again.