CANN社区版安装指南(3.3.0.alphaX)CANN社区版安装指南(3.3.0.alphaX)

计算
弹性云服务器 ECS
裸金属服务器 BMS
云手机 CPH
专属主机 DeH
弹性伸缩 AS
镜像服务 IMS
函数工作流 FunctionGraph
云耀云服务器 HECS
VR云渲游平台 CVR
特惠算力专区
存储
对象存储服务 OBS
云硬盘 EVS
云备份 CBR
弹性文件服务 SFS
存储容灾服务 SDRS
云硬盘备份 VBS
云服务器备份 CSBS
数据快递服务 DES
专属企业存储服务
云存储网关 CSG
专属分布式存储服务 DSS
CDN与智能边缘
内容分发网络 CDN
智能边缘云 IEC
智能边缘小站 IES
智能边缘平台 IEF
人工智能
AI开发平台ModelArts
华为HiLens
图引擎服务 GES
图像识别 Image
文字识别 OCR
自然语言处理 NLP
内容审核 Moderation
图像搜索 ImageSearch
医疗智能体 EIHealth
园区智能体 CampusGo
企业级AI应用开发专业套件 ModelArts Pro
人脸识别服务 FRS
对话机器人服务 CBS
视频分析服务 VAS
语音交互服务 SIS
知识图谱 KG
人证核身服务 IVS
IoT物联网
设备接入 IoTDA
设备管理 IoTDM(联通用户专用)
全球SIM联接 GSL
IoT开发者服务
IoT数据分析
车联网服务 IoV
路网数字化服务 DRIS
IoT边缘 IoTEdge
设备发放 IoTDP
开发与运维
软件开发平台 DevCloud
项目管理 ProjectMan
代码托管 CodeHub
流水线 CloudPipeline
代码检查 CodeCheck
编译构建 CloudBuild
部署 CloudDeploy
云测 CloudTest
发布 CloudRelease
移动应用测试 MobileAPPTest
CloudIDE
Classroom
开源镜像站 Mirrors
应用魔方 AppCube
云性能测试服务 CPTS
应用管理与运维平台 ServiceStage
云应用引擎 CAE
视频
实时音视频 SparkRTC
视频直播 Live
视频点播 VOD
媒体处理 MPC
视频接入服务 VIS
管理与监管
统一身份认证服务 IAM
消息通知服务 SMN
云监控服务 CES
应用运维管理 AOM
应用性能管理 APM
云日志服务 LTS
云审计服务 CTS
标签管理服务 TMS
资源管理服务 RMS
应用身份管理服务 OneAccess
区块链
区块链服务 BCS
可信跨链服务 TCS
智能协作
IdeaHub
开发者工具
SDK开发指南
API签名指南
DevStar
HCloud CLI
Terraform
Ansible
API问题定位指导
云生态
云市场
合作伙伴中心
华为云培训中心
其他
管理控制台
消息中心
产品价格详情
系统权限
我的凭证
客户关联华为云合作伙伴须知
公共问题
宽限期保留期
奖励推广计划
活动
容器
云容器引擎 CCE
云容器实例 CCI
容器镜像服务 SWR
应用编排服务 AOS
多云容器平台 MCP
基因容器 GCS
容器洞察引擎 CIE
云原生服务中心 OSC
容器批量计算 BCE
容器交付流水线 ContainerOps
应用服务网格 ASM
网络
虚拟私有云 VPC
弹性公网IP EIP
弹性负载均衡 ELB
NAT网关 NAT
云专线 DC
虚拟专用网络 VPN
云连接 CC
VPC终端节点 VPCEP
数据库
云数据库 RDS
数据复制服务 DRS
文档数据库服务 DDS
分布式数据库中间件 DDM
云数据库 GaussDB (for openGauss)
云数据库 GaussDB(for MySQL)
云数据库 GaussDB NoSQL
数据管理服务 DAS
数据库和应用迁移 UGO
大数据
MapReduce服务 MRS
数据湖探索 DLI
表格存储服务 CloudTable
可信智能计算服务 TICS
推荐系统 RES
云搜索服务 CSS
数据可视化 DLV
数据湖治理中心 DGC
数据接入服务 DIS
数据仓库服务 GaussDB(DWS)
应用中间件
微服务引擎 CSE
分布式消息服务Kafka版
分布式消息服务RabbitMQ版
API网关 APIG
分布式缓存服务 DCS
分布式消息服务RocketMQ版
企业应用
域名注册服务 Domains
云解析服务 DNS
云速建站 CloudSite
网站备案
华为云WeLink
会议
隐私保护通话 PrivateNumber
语音通话 VoiceCall
消息&短信 MSGSMS
云管理网络
SD-WAN 云服务
边缘数据中心管理 EDCM
云桌面 Workspace
应用与数据集成平台 ROMA Connect
ROMA资产中心 ROMAExchange
API全生命周期管理 ROMA API
安全与合规
安全技术与应用
DDoS防护 ADS
Web应用防火墙 WAF
云防火墙 CFW
应用信任中心 ATC
企业主机安全 HSS
容器安全服务 CGS
云堡垒机 CBH
数据库安全服务 DBSS
数据加密服务 DEW
数据安全中心 DSC
云证书管理服务 CCM
SSL证书管理 SCM
漏洞扫描服务 VSS
态势感知 SA
威胁检测服务 MTD
管理检测与响应 MDR
安全治理云图 Compass
迁移
主机迁移服务 SMS
对象存储迁移服务 OMS
云数据迁移 CDM
专属云
专属计算集群 DCC
解决方案
高性能计算 HPC
SAP
游戏云
混合云灾备
华为工业云平台 IMC
价格
成本优化最佳实践
专属云商业逻辑
用户服务
帐号中心
费用中心
成本中心
资源中心
企业管理
工单管理
客户运营能力
国际站常见问题
支持计划
专业服务
合作伙伴支持计划
更新时间:2021-10-26 GMT+08:00
分享

Ubuntu x86_64系统

环境要求

开发环境需要安装以下软件或依赖,请参照本章节操作流程完成所需依赖安装。

表1 依赖信息

类别

版本限制

Python

3.7.5

cmake

3.5.1+

make

-

gcc

7.3.0及以上

g++

7.3.0及以上

zlib1g

zlib1g-dev

libbz2-dev

libsqlite3-dev

libssl-dev

libxslt1-dev

libffi-dev

unzip

pciutils

net-tools

liblapack-dev

liblapack3

libblas-dev

gfortran

libblas3

sudo

无版本要求,安装的版本以操作系统自带的源为准。

numpy

>=1.13.3 && <1.20

decorator

>=4.4.0

sympy

1.4

cffi

1.12.3

protobuf

3.11.3+

xlrd

1.2.0

attrs

pyyaml

pathlib2

scipy

requests

psutil

无版本要求,安装的版本以pip源为准。

检查源

深度学习引擎包、实用工具包和框架插件包安装过程需要下载相关依赖,请确保安装环境能够连接网络。

请在root用户下执行如下命令检查源是否可用。

apt-get update

如果命令执行报错或者后续安装依赖时等待时间过长甚至报错,则检查网络是否连接或者把“/etc/apt/sources.list”文件中的源更换为可用的源或使用镜像源(以配置华为镜像源为例,可参考华为开源镜像站)。如需配置网络代理,请参见配置系统网络代理

配置安装用户权限

当用户使用非root用户安装时,需要操作该章节;当用户使用root用户安装时,仅需执行步骤1

请以root用户执行如下操作。

  1. 安装sudo,使用如下命令安装。
    apt-get install sudo
  2. 打开“/etc/sudoers”文件:
    chmod u+w /etc/sudoers
    vi /etc/sudoers
  3. 在该文件中添加如下内容:
    username ALL=(ALL:ALL) NOPASSWD:SETENV:/usr/bin/apt-get, /usr/bin/pip, /bin/tar, /bin/mkdir, /bin/sh, /bin/bash, /usr/bin/make install, /bin/ln -s /usr/local/python3.7.5/bin/python3 /usr/local/python3.7.5/bin/python3.7.5, /bin/ln -s /usr/local/python3.7.5/bin/pip3 /usr/local/python3.7.5/bin/pip3.7.5, /usr/bin/unzip, /usr/bin/find /etc -name openssl.cnf

    其中username代表安装用户,请根据实际替换。

    • 请确保“ /etc/sudoers”文件存在“ #includedir /etc/sudoers.d”,如果没有该信息,请手动添加至文件末尾。
    • 用户在完成CANN软件包安装后,可自行取消sudo权限。
    • 用户在卸载或升级CANN软件包时,也需配置以上用户权限。
  4. 添加完成后,执行:wq!保存文件。
  5. 执行以下命令取消“/etc/sudoers”文件的写权限:
    chmod u-w /etc/sudoers

安装依赖

  1. 检查系统是否安装python依赖以及gcc等软件。

    分别使用如下命令检查是否安装gcc,make以及python依赖软件等。
    gcc --version
    g++ --version
    make --version
    cmake --version
    dpkg -l zlib1g| grep zlib1g| grep ii
    dpkg -l zlib1g-dev| grep zlib1g-dev| grep ii
    dpkg -l libbz2-dev| grep libbz2-dev| grep ii
    dpkg -l libsqlite3-dev| grep libsqlite3-dev| grep ii
    dpkg -l openssl| grep openssl| grep ii
    dpkg -l libssl-dev| grep libssl-dev| grep ii
    dpkg -l libxslt1-dev| grep libxslt1-dev| grep ii
    dpkg -l libffi-dev| grep libffi-dev| grep ii
    dpkg -l unzip| grep unzip| grep ii
    dpkg -l pciutils| grep pciutils| grep ii
    dpkg -l net-tools| grep net-tools| grep ii

    若分别返回如下信息则说明已经安装,进入下一步(以下回显仅为示例,请以实际情况为准)。

    gcc (Ubuntu 7.5.0-3ubuntu1~18.04) 7.5.0
    g++ (Ubuntu 7.5.0-3ubuntu1~18.04) 7.5.0
    GNU Make 4.1
    cmake version 3.10.2
    zlib1g:amd64   1:1.2.11.dfsg-0ubuntu2 amd64        compression library - runtime
    zlib1g-dev:amd64  1:1.2.11.dfsg-0ubuntu2  amd64        compression library - development
    libbz2-dev:amd64    1.0.6-8.1ubuntu0.2 amd64        high-quality block-sorting file compressor library - development
    libsqlite3-dev:amd64    3.22.0-1ubuntu0.3 amd64        SQLite 3 development files
    openssl        1.1.1-1ubuntu2.1~18.04.6 amd64        Secure Sockets Layer toolkit - cryptographic utility
    libssl-dev:amd64    1.1.1-1ubuntu2.1~18.04.6 amd64        Secure Sockets Layer toolkit - development files
    libxslt1-dev:amd64 1.1.29-5ubuntu0.2 amd64        XSLT 1.0 processing library - development kit
    libffi-dev:amd64 3.2.1-8      amd64        Foreign Function Interface library (development files)
    unzip          6.0-21ubuntu1 amd64        De-archiver for .zip files
    pciutils       1:3.5.2-1ubuntu1 amd64        Linux PCI Utilities
    net-tools      1.60+git20161116.90da8a0-1ubuntu1 amd64        NET-3 networking toolkit
    否则请执行如下安装命令(如果只有部分软件未安装,则如下命令修改为只安装还未安装的软件即可):
    • 如果使用root用户安装依赖,请将步骤1至步骤2命令中的sudo删除。
    • 如果python及其依赖是使用非root用户安装,则需要执行su - username命令切换到非root用户继续执行步骤1至步骤3
    • libsqlite3-dev需要在python安装之前安装,如果用户操作系统已经安装python3.7.5环境,在此之后再安装libsqlite3-dev,则需要重新编译python环境。
    sudo apt-get install -y gcc g++ make cmake zlib1g zlib1g-dev libbz2-dev libsqlite3-dev libssl-dev libxslt1-dev libffi-dev unzip pciutils net-tools libncursesw5-dev 

  2. 检查系统是否安装python开发环境。

    分别使用命令python3.7.5 --versionpip3.7.5 --version检查是否已经安装,如果返回如下信息则说明已经安装,进入下一步。

    Python 3.7.5
    pip 19.2.3 from /usr/local/python3.7.5/lib/python3.7/site-packages/pip (python 3.7)

    否则请根据如下方式安装python3.7.5。

    1. 使用wget下载python3.7.5源码包,可以下载到安装环境的任意目录,命令为:
      wget https://www.python.org/ftp/python/3.7.5/Python-3.7.5.tgz
    2. 进入下载后的目录,解压源码包,命令为:
      tar -zxvf Python-3.7.5.tgz
    3. 进入解压后的文件夹,执行配置、编译和安装命令:
      cd Python-3.7.5
      ./configure --prefix=/usr/local/python3.7.5 --enable-loadable-sqlite-extensions --enable-shared
      make
      sudo make install

      其中“--prefix”参数用于指定python安装路径,用户根据实际情况进行修改。“--enable-shared”参数用于编译出libpython3.7m.so.1.0动态库。“--enable-loadable-sqlite-extensions”参数用于加载libsqlite3-dev依赖。

      本手册以--prefix=/usr/local/python3.7.5路径为例进行说明。执行配置、编译和安装命令后,安装包在/usr/local/python3.7.5路径,libpython3.7m.so.1.0动态库在/usr/local/python3.7.5/lib/libpython3.7m.so.1.0路径。

    4. 执行如下命令设置软链接:
      sudo ln -s /usr/local/python3.7.5/bin/python3 /usr/local/python3.7.5/bin/python3.7.5
      sudo ln -s /usr/local/python3.7.5/bin/pip3 /usr/local/python3.7.5/bin/pip3.7.5
    5. 配置python3.7.5环境变量。
      #用于设置python3.7.5库文件路径
      export LD_LIBRARY_PATH=/usr/local/python3.7.5/lib:$LD_LIBRARY_PATH
      #如果用户环境存在多个python3版本,则指定使用python3.7.5版本
      export PATH=/usr/local/python3.7.5/bin:$PATH
    6. 安装完成之后,执行如下命令查看安装版本,如果返回相关版本信息,则说明安装成功。
      python3.7.5 --version
      pip3.7.5  --version

  3. 安装前请先使用pip3.7.5 list命令检查是否安装相关依赖,若已经安装,则请跳过该步骤;若未安装,则安装命令如下(如果只有部分软件未安装,则如下命令修改为只安装还未安装的软件即可)。

    • 请在安装前配置好pip源,具体可参考配置pip源
    • 安装前,建议执行命令pip3.7 install --upgrade pip进行升级,避免因pip版本过低导致安装失败。
    • 如下命令如果使用非root用户安装,需要在安装命令后加上--user,例如:pip3.7.5 install decorator --user,安装命令可在任意路径下执行。
    • 要求numpy版本大于等于1.13.3且小于1.20,推荐numpy版本为1.17.2。
    pip3.7.5 install attrs
    pip3.7.5 install numpy==1.17.2
    pip3.7.5 install decorator
    pip3.7.5 install sympy==1.4
    pip3.7.5 install cffi==1.12.3
    pip3.7.5 install pyyaml
    pip3.7.5 install pathlib2
    pip3.7.5 install psutil
    pip3.7.5 install protobuf
    pip3.7.5 install scipy
    pip3.7.5 install requests
    pip3.7.5 install xlrd==1.2.0

    如果执行上述命令时报错“subprocess.CalledProcessError:Command '('lsb_release', '-a')' return non-zero exit status 1”,请参见pip3.7.5 install报错“subprocess.CalledProcessError:Command '('lsb_release', '-a')' return non-zero exit status 1”

分享:

    相关文档

    相关产品

关闭导读