
# 开启双因子认证后登录主机失败？
登录主机失败的原因可能为文件配置错误或登录方式错误导致。
#### 文件配置错误
您可检查配置文件是否正确。
配置文件路径：/etc/ssh/sshd_config
需要确认的配置文件项：
PermitEmptyPasswords no
UsePAM yes
ChallengeResponseAuthentication yes
![](https://support.huaweicloud.com/hss2.0_faq/public_sys-resources/note_3.0-zh-cn.png)
如果您使用的是root登录，还需要配置文件项为：
PermitRootLogin yes
#### 登录方式错误
失败原因：开启双因子认证后，可能是通过以下方式登录云主机导致登录失败。
- 通过CloudShell工具登录云主机。
- Linux主机中，通过云堡垒机登录云主机。
根本原因：双因子的验证实现是通过内置模块进行验证，由于以上登录方式无法弹出交互页面，导致验证失败。
解决办法：您可参照[如何使用双因子认证？](https://support.huaweicloud.com/hss2.0_faq/hss_01_0437.html)重新登录认证。
![](https://support.huaweicloud.com/hss2.0_faq/public_sys-resources/note_3.0-zh-cn.png)
开启双因子的前提条件、约束与限制更多详情请参见[安全配置](https://support.huaweicloud.com/usermanual-hss2.0/hss_01_0051.html)章节中的"开启双因子认证"。
