
# 常见问题
#### SMS迁移问题
**问题1：迁移中源端有新增的数据如何处理？**
回答：启动目的端后，如果源端有新增的数据，单击此服务器所在行的操作列的"同步"，开始下一次复制（增量数据），当迁移状态为"持续同步"时，单击"启动目的端"，迁移实时状态为"已完成"时，说明新增数据已同步到目的端。
**问题2：迁移过程中目的端为什么多出来一个40G的磁盘？**
回答：主机迁移服务在迁移过程中会在目的端服务器临时创建并挂载一个容量为40GB的磁盘，用于辅助迁移，该磁盘会在迁移结束后自动删除。迁移期间，请勿对该磁盘进行删除操作或将计费模式转为包周期操作，否则会导致迁移失败。
#### 数据库迁移问题
**问题3：DRS支持断点续传吗？**
回答：针对数据库的迁移、同步场景，在迁移、同步过程中由于不可抗拒因素（例如网络波动）导致的任务失败，DRS通过记录当前解析和回放的位点（该位点同时也是数据库内部一致性的依据），下次从该位点开始回放的方式来实现断点续传，以确保数据的完整性。
增量阶段的迁移、同步，DRS会自动进行多次断点续传的重试，全量阶段的MySQL迁移，系统默认进行三次自动续传，无需人工干预。当自动重试失败累计一定次数后，任务会显示异常，需要人为根据日志来分析无法继续的原因，并尝试解决阻塞点（例如数据库修改了密码），如果环境无法修复，如所需日志已经淘汰，则使用重置功能可以完全重新开始任务。
**问题4：MySQL迁移出现数据膨胀怎么办？**
回答：DRS在全量迁移阶段，为了保证迁移性能和传输的稳定性，采用了行级并行的迁移方式。当源端数据紧凑情况下，通过DRS迁移到云上RDS for MySQL后，可能会出现数据膨胀现象，使得磁盘空间使用远大于源端。针对这种情况，客户可选择在目标库中执行以下命令，进行优化整理从而缩小空间。
```
optimize table table_name
```
![](https://support.huaweicloud.com/hcmpis-cmgrt/public_sys-resources/note_3.0-zh-cn.png)
由于命令optimize会进行锁表操作，所以进行优化时要避开表数据操作时间，避免影响正常业务的进行。
#### 对象存储迁移问题
**问题5：源端云服务商不在OMS支持范围，该如何迁移？**
回答：源端对象可以通过HTTP或HTTPS公开访问，且用户能够自行列举出所有待迁移对象名称和对应的下载链接。
**问题6：为什么有时候迁移速度会很慢?**
回答：迁移速度的影响因素很多，比如迁移的对象大小、正在迁移的对象个数、网络传输情况等。在不考虑网络环境的情况下分析迁移速度慢的原因可能有下面几个方面：
- 大量的小对象
由于每个迁移任务的最大并发数是固定的，导致同时在迁移的对象数是有限制的。迁移前会列举对象，每个对象迁移完成后，都会对比源端和目的端是否一致。相比于迁移大对象，迁移同样大小的数据量，会有更多的列举对象和对比对象操作带来的时间消耗。
解决方式：通过创建迁移任务组，将源端待迁移对象智能拆分到多个迁移任务中并行迁移，提升迁移速度。
- 迁移数量较少的大对象
当迁移的对象数量较少（小于50个）且大小很大时，由于只会有一个线程迁移单个对象，对象数又较少，导致迁移的并发低，所以迁移速度会较慢。
这种情况请耐心等待，无法提升迁移的速度。
#### SFS迁移问题
**问题7：文件系统中的数据是否可以跨区域迁移？**
回答：暂时不支持直接跨区域迁移文件系统数据，您需要在购买文件系统时规划好合适的区域，或者可以将数据复制至本地后再传至另一区域。
SFS Turbo文件系统可以使用云备份进行备份数据，再使用备份复制的功能，将备份副本复制至另一区域再创建一个与原区域数据一致的SFS Turbo文件系统进行使用。
#### KAFKA迁移问题
**问题8：Kafka消息堆积了怎么办？**
回答：
1. 登录Kafka实例控制台，单击产生告警的实例名称，进入实例详情页。
2. 在左侧导航栏，单击"监控"，进入监控页面。
3. 在"消费组"页签中，查看"消息堆积数（消费组可消费消息数）"，找出消息堆积的消费组。
4. 在左侧导航栏，单击"消费组管理"，进入消费组列表页面。
5. 查看消息堆积的消费组是否有消费者在消费，如果有，让业务方加快消费效率，如果没有，酌情删掉不使用的消费组。
**问题9：为什么删除消费组不生效？**
回答：您开启了自动创建消费组功能，且业务代码正在连接该消费组。所以，如果没有停止您的业务，删除了消费组后，消费消息时还是会自动创建该消费组。关闭自动创建消费组功能，即在Kafka控制台的"配置参数"页面，把"auto.create.groups.enable"设置为"false"，然后再删除消费组。部分实例在"配置参数"中没有"auto.create.groups.enable"参数，具体以控制台为准，此时建议修改业务代码，使业务代码不再连接该消费组，然后再删除消费组。
#### DCS迁移问题
**问题10：如果Redis实例发生了主备倒换，可能会导致迁移失败？**
回答：将主备倒换关闭，待迁移成功后，再开启主备倒换。
**问题11：主备规格如何导出redis实例数据**？
回答：
1. 进入缓存管理页面，切换到"备份与恢复"页签，查看实例的备份记录。
2. 如没有记录，则手动执行备份动作，执行完后，单击"下载"，根据提示完成数据的下载操作。
#### DDS迁移问题
**问题12 ：DDS实例是否支持跨region迁移**
回答：可以使用数据复制服务（Data Replication Service，简称DRS）实现云上跨Region的数据库之间的迁移。
