
# sssd 2.9.0及之后版本切换至HCE sssd 2.6.1后LDAP鉴权失败
#### 问题背景
使用 sssd 2.9.0 及之后的版本，在切换至 HCE 2.0 的 sssd 2.6.1 版本后，若 /etc/sssd/sssd.conf配置文件中没有指定enable_files_domain配置决定是否使用本地认证，则可能导致LDAP鉴权失败。
#### 问题原因
HCE 2.0 环境使用sssd 2.6.1版本，在sssd 2.9.0及之后的版本中，开源社区修改了enable_files_domain默认值为false，本地认证不开启，会优先使用远端认证。而 HCE 的sssd 2.6.1版本本地认证开启，若没有在配置文件中指定enable_files_domain = false，则会优先走本地认证，若本地用户未配置密码会导致鉴权失败。
#### 解决办法
在HCE 环境 sssd 认证配置文件（/etc/sssd/sssd.conf）中，添加 enable_files_domain = false 配置验证，关闭本地认证，默认走远端认证。
