
# FlexusRDS for MySQL的root账号为什么没有super权限
FlexusRDS for MySQL没有给root账号提供super权限。因为一旦用户拥有了super权限，就可以执行很多管理性的命令，比如reset master，set global...，reset slave等，很有可能导致主备关系异常而出现故障。
对于客户要求super权限的场景，只能通过Flexus云数据库RDS提供的服务化能力处理，或者通过其他手段绕过super权限的限制。示例如下：
示例1：登录数据库执行 **set global** *参数名* **=** *参数值* **;** 命令来修改参数，这在FlexusRDS for MySQL是被禁止的，参数修改只能通过界面的参数修改功能来实现。
示例2：执行 **create definer='root'@'%' trigger(procedure)...** 命令出现报错，这也是因为没有super权限导致的，只需要去除**definer='root'**关键字即可。
