Updated on 2024-04-11 GMT+08:00

ALM-28001 Spark Service Unavailable (For MRS 2.x or Earlier)

Description

The system checks the Spark service status every 30 seconds. This alarm is generated when the Spark service is unavailable.

This alarm is cleared when the Spark service recovers.

Attribute

Alarm ID

Alarm Severity

Auto Clear

28001

Critical

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

The Spark tasks submitted by users fail to be executed.

Possible Causes

  • The KrbServer service is abnormal.
  • The LdapServer service is abnormal.
  • The ZooKeeper service is abnormal.
  • The HDFS service is abnormal.
  • The Yarn service is abnormal.
  • The corresponding Hive service is abnormal.

Procedure

  1. Check whether service unavailability alarms exist in services that Spark depends on.

    1. Go to the MRS cluster details page and choose Alarms.
    2. Check whether the following alarms exist in the alarm list:
      1. ALM-25500 KrbServer Service Unavailable
      2. ALM-25000 LdapServer Service Unavailable
      3. ALM-13000 ZooKeeper Service Unavailable
      4. ALM-14000 HDFS Service Unavailable
      5. ALM-18000 Yarn Service Unavailable
      6. ALM-16004 Hive Service Unavailable
      • If yes, go to 1.c.
      • If no, go to 2.
    3. Handle the alarms based on the troubleshooting methods provided in the alarm help.

      After the alarm is cleared, wait a few minutes and check whether the alarm HetuServer Service Unavailable is cleared.

      • If yes, no further action is required.
      • If no, go to 2.

  2. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M engineers and send the collected logs.

Reference

None